Remote installation of HP Dataprotector 6.20 client on Ubuntu 12.04 with 3.2 kernel

During std. remote installation (in Manager GUI) installer instantly ends with error – „unsupported platform / OS“.

I found out that problem is with 3.2 kernel version (only with the NUMBER not the code) and the workaround (until HP create patch) is to modify uname.

  • move /bin/uname to /bin/uname.orig
  • create executable script /bin/uname with this:
    /bin/uname.orig $1 | sed 's/3\.2\.0/2\.6\.32/'

Explanation: when something call uname and in output is  3.2.0 (real kernel number), then is replaced by ‚2.6.32‘.

After successfull installation you can use orig. uname again – backup work fine.